Kadince - App is down – Incident details

App is down

Resolved
Major outage
Started 10 days agoLasted 2 minutes

Affected

App

Operational from 5:00 PM to 5:00 PM, Major outage from 5:00 PM to 5:02 PM

Updates
  • Postmortem
    Postmortem

    Summary

    Kadince experienced a period of intermittent availability and slow performance affecting parts of the Community → Events module.

    Impact

    During the incident window, some users experienced slow page loads and occasional errors when accessing event-related pages.

    Root Cause

    A recent update introduced an inefficient database query related to event registration permissions. Under certain conditions, this query placed excessive load on the database, leading to degraded performance.

    Resolution

    We reverted the affected change and updated the query logic to prevent the issue from recurring. System performance returned to normal shortly after the fix was deployed.

    Prevention

    We are implementing additional safeguards around query performance and release validation to better detect and prevent similar issues in the future.

  • Resolved
    Resolved
    App is back up. This incident was automatically resolved by Instatus monitoring.
  • Investigating
    Investigating
    App is down at the moment. This incident was automatically created by Instatus monitoring.